Password Considerations in the Wake of Heartbleed

Posted on April 29, 2014 by | 0 comments

, , , , ,

You may be wondering if the recent OpenSSL “Heartbleed” security vulnerability affects you. The answer is yes, it affects everyone regardless if you are an Advance customer or not. Many of the websites you visit on a daily basis use OpenSSL to secure communications. This includes sites that require usernames and passwords to access those resources, such as email, IM and VPNs. Read more »